Canon imageRUNNER ADVANCE C5235i Blank Screen Only Power Light and Energy Saver Light On

      Comments Off on Canon imageRUNNER ADVANCE C5235i Blank Screen Only Power Light and Energy Saver Light On

Canon imageRUNNER ADVANCE C5235i Blank Screen Only Power Light and Energy Saver Light On

Well, it’s been a while but time to share my latest major repair on a Canon machine. I was asked to attend site with a colleague not too familiar with Canon copiers to look at a Canon irac5235i with a blank screen. It only had the power light on the front of the control panel and the nergy saver light on. I tried to enter into self diagnostic mode by turning on the machine with the numbers 2 and 4 pressed according to the 5235i service manual. The idea is that the power LED will flash in a specific sequence to indicate which board could be at fault. Anyway, this was unsuccesful as it did nothing which suggested a power issue so after a few tests we ordered the main power supply which brought the machine to life. But then…….error code E0732-0021. Oh no!

Just in case you have never come across this error before it relates to the reader and suggests no communication with the reader board. Now just to make a point of really reallychecking your connectors properly, I thought I had checked all the PSU connectors but must have done so more visually that physically. Anyway, replaced the reader controller which was another error because without checking for power this was futile. To cut a long and painful story short, the problem was this:

That connector supplies power to the reader controller PCB in case you need to know this quickly in the future and it looked as though it was plugged in properly until I actually gripped it firmly to realise it was just sitting there. Wow! Don’t tell anyone I did this. Anyway, I’m not too proud to share my errors for the benefit of the masses. If you don’t already have the Canon IRA c5235i service manual then you can download it here.

See you later. Gotta go look at a Kyocera TA 7551ci where the customer has complained of a burning smell. Probably the new fused but I had better go see them.